Linux下EasyPanel及PHP安装升级

Linux下EasyPanel版本安装及升级

    关于easypanel&kangle产品介绍

kangle.png

    easypanel 是一款免费的功能强大集开通虚拟主机,ftp空间,数据库等功能为一体的主机控制面板 , 具备跨平台(windows,linux),安全稳定、操作简便等特点。支持php(windows版本还支持asp,asp.net),支持磁盘配额,在线文件管理,在线web软件安装。

    说明: 1、windows版,安装easypanel前,需要先安装kangle web服务器软件。 easypanel是在kangle web服务器软件基础上架设,是对kangle功能的调用。 

               2、windows版,easypanel没有集成mysql,mysql需要用户自已另外下载安装。

    下载地址&安装方法:

    1、windows下easypanel版本安装及升级

    32位下载(配合32位的kangle)

    64位下载(配合64位的kangle)

    2、linux下easypanel版本安装及升级

yum -y install wget;yum -y install screen;screen -S ep;wget http://download.kangleweb.com/easypanel/ep.sh -O ep.sh;sh ep.sh

    等待到最后会提示please visit http://ip:3312/admin to continue

    初始账号为admin,密码为kangle。

注:centos系统下easypanel集成的php默认装的是php53,语言模块里显示的php52其实是php53版本;如果需要php5217版本,请使用以下脚本安装

Kangle EasyPanel php5.2.17 for linux版(集成zend和ioncube

wget http://github.itzmx.com/1265578519/kangle/master/php/5.2/5217/php5217.sh -O php5217.sh;sh php5217.sh

php.ini路径为 /vhs/kangle/ext/tpl_php5217/php-templete.ini


Kangle EasyPanel php5.4.45 for linux版(集成zend和ioncube

wget http://github.itzmx.com/1265578519/kangle/master/php/5.4/5445/php5445.sh -O php5445.sh;sh php5445.sh

php.ini路径为 /vhs/kangle/ext/tpl_php5445/php-templete.ini


Kangle EasyPanel php5.5.38 for linux版(集成Zend OPcache和ioncube

wget http://github.itzmx.com/1265578519/kangle/master/php/5.5/5538/php5538.sh -O php5538.sh;sh php5538.sh

php.ini路径为 /vhs/kangle/ext/tpl_php5538/php-templete.ini


Kangle EasyPanel php5.6.24 for linux版(集成Zend OPcache和ioncube

wget http://github.itzmx.com/1265578519/kangle/master/php/5.6/5624/php5624.sh -O php5624.sh;sh php5624.sh

php.ini路径为 /vhs/kangle/ext/tpl_php5624/php-templete.ini


Kangle EasyPanel php7.0.9 for linux版(集成Zend OPcache和ioncube

wget http://github.itzmx.com/1265578519/kangle/master/php/7.0/709/php709.sh -O php709.sh;sh php709.sh

php.ini路径为 /vhs/kangle/ext/tpl_php709/php-templete.ini


以上脚本兼容各版本easypanel(64,32)

关于easypanel php版本出错,空白问题

1.jpg

2.png


如果切换不生效,请在用户控制面板中随意切换一个空白版本,然后访问,确认是出错版本后回到后台,再为其选择旧格式中的其他版本即可生效~!


Leave a Comment